Jump to content
helys

Da Lantano Sud

Recommended Posts

Il 12/4/2019 alle 13:44, jango ha scritto:

Ma spostati assolutamente su TRS2019 !

Mantieni pure TANE come "scorta" per gli oggetti da importare, se non li trovi sulla DLS.

Da TANE fai un cdp comprensivo di tutti quelli che ti mancano, poi li installi su TRS2019.

 

Il CDP importato da TANE, come suggerito, contiene 28 oggetti missing. NESSUNO DI QUESTI OGGETTI FUNZIONA IN TRS2019 e a nulla valgono i molteplici tentativi di correggere gli errori. Gli oggetti sono tutti faulty o con missing dependancies introvabili.

Non so più che fare...e mi viene voglia di restare su TANE, salvo sostituire gli oggetti (cosa che non mi piace, visto che li avevo scelti)

Qualche suggerimento?

 

:ciao:

Share this post


Link to post

Strano. Quello che funziona in TANE dovrebbe funzionare anche il TRS19. Potrebbero essere oggetti built-in non conformi "forzati" da auran e quindi creando un cdp ed importandoli in TRS19 perdono la forzatura diventando faulty.

 

Share this post


Link to post

1. Che errori sono ? Puoi copiare qui la dicitura ?

2. Missing dependencies : se non ti danno errore in TANE, le dipendenze dovresti trovarle in TANE e copiarle.

3. Per l'elenco completo degli oggetti devi usare "List dependencies recursively" nel CM menù "Content". L'opzione c'è anche in TANE, visto che il CM è rimasto inalterato.

4. Gli oggetti sono essenziali o possono essere sostituiti da più aggiornati ? Se sono di TZIT dovrebbero essere aggiornati, se sono di altri siti o DLS controlla che ci siano aggiornamenti.

Se non ci sono...elimina.

5. Vuoi rimanere in TANE per 28 oggetti ?  Nessun problema per te, ma io scaricherò la tua tratta in TRS19, non in TANE....e gli oggetti faulty o mancanti li eliminerò.

 

ciao dottò !

 

  • Like 1

Share this post


Link to post

Stavolta il salto tra TANE e TRS19 è significativo e non è solo fuffa, te lo dice uno che è stato molto scettico in passato.

  • Like 1

Share this post


Link to post

Presumibilmente si tratta di oggetti built-in in T:ANE ma non in TRS19, provenienti da siti terzi e non presenti sulla DLS. 
Lo stesso problema (oggetti mancanti ed introvabili) si è verificato con l'ultima versione della Relax, che contiene oggetti built-in in TS2010 ma non in TS12 e non presenti in DLS e con un oggetto nella tratta di itadriver (vedi QUI).

In questi casi, o si riesce a trovare - ammesso che esista ancora - il sito di provenienza degli oggetti, oppure l'unica soluzione praticabile è sostituire gli oggetti.

 

Circa il fatto che gli oggetti siano difettosi, secondo me può dipendere dal fatto che abbiano le texture compresse (file .TEXTURE) o da qualche altra causa similare. Per le dipendenze mancanti, sicuramente sono presenti in T:ANE, ma probabilmente soffriranno degli stessi problemi. Quasi certamente si riesce a renderli funzionanti ma per gli utenti che scaricheranno la tratta rimarrà il problema di reperirli

 

Tutto ciò premesso, continuare in T:ANE non risolve il problema, ma rimanda solamente il momento in cui bisognerà affrontarlo.

Share this post


Link to post
3 ore fa, helys ha scritto:

 

..e mi viene voglia di restare su TANE, salvo sostituire gli oggetti (cosa che non mi piace, visto che li avevo scelti)

Qualche suggerimento?

Come già scritto Venerdi :

Se ti decidi a buttare T:ane nel cesso , fai cosa buona e giusta e ti togli la rogna una volta per tutte.

Se li modifichi, poi hai il dilemma "li alligo o no alla tratta?"

Se si, al massimo ti arriva qualche letteraccia dall'autore/auran.

Se no, sicuramente una sequela di "vai a c..." da parte di chi la scarica.

Ti ricordo che tutto questo l'abbiamo già detto su .com quando mi hai mandato la beta.

Share this post


Link to post

Non prendetela sottogamba, l'opzione " List dependencies recursively " è essenziale per chi crea cdp delle tratte.

Share this post


Link to post

Non l'avevo mai notata.

L'ho usata adesso, ad occhio direi che elenca sia gli asset usati che le loro dipendenze.

Giusto?

Share this post


Link to post
3 ore fa, ettore48 ha scritto:

Non l'avevo mai notata.

L'ho usata adesso, ad occhio direi che elenca sia gli asset usati che le loro dipendenze.

Giusto?

Direi di sì, salvo "cangurate" nascoste.....

Share this post


Link to post

Ok, ragazzi. Grazie a tutti dei suggerimenti. Utilizzerò il 2019 e, come mi ha suggerito lo zio al punto 4 del suo post, eliminerò gli oggetti (28) che non sono passati, sostituendoli o con versioni più aggiornate, se disponibili sulla DS, o con altri simili. 

Devo, però, adesso, istallare il 2019 anche sul portatile, perché lavoro con entrambi (vedremo le performance come saranno). Questo sistema mi permette anche di avere una copia di sicurezza del CDP.

Su uno dei due, però TANE non lo disistallerò. Potrebbe sempre tornarmi utile.

 

:ciao:

Share this post


Link to post

TANE va tenuto solo per "magazzino" degli oggetti e se vuoi provare alcune tratte scaricate per TANE senza importarle in TRS19, evitando intasamenti inutili in TRS.

Share this post


Link to post

Io ho risolto con due installazioni di trs19. Una da "lavoro" e l'altra solo con oggetti delle tratte. Ho lasciato il passato 🙂

Share this post


Link to post
Il 14/4/2019 alle 12:53, UP844 ha scritto:

.......

Circa il fatto che gli oggetti siano difettosi, secondo me può dipendere dal fatto che abbiano le texture compresse (file .TEXTURE) o da qualche altra causa similare. Per le dipendenze mancanti, sicuramente sono presenti in T:ANE, ma probabilmente soffriranno degli stessi problemi. Quasi certamente si riesce a renderli funzionanti ma per gli utenti che scaricheranno la tratta rimarrà il problema di reperirli

 

Tutto ciò premesso, continuare in T:ANE non risolve il problema, ma rimanda solamente il momento in cui bisognerà affrontarlo.

 

Infatti, Carlo. È l'errore più comune. Ma PEV SOft con texture2tga o image2tga non risolve il problema. Mi dà errore e si blocca.

Giusto a titolo di curiosità e per aver corretto la maggior parte delle incopatibilità, nelle versioni precedenti, c'è qualcosa che posso fare?

Grazie

 

:ciao:

Share this post


Link to post

Ho cercato a lungo sul forum Auran: i file in formato .TEXTURE di T:ANE e TRS19 non possono essere convertiti in file .TGA + file .texture.TXT. Anche se l'estensione è la stessa, la codifica è diversa, presumibilmente per via delle nuove opzioni delle texture PBR. 

 

Tutti i nostri modelli che sto aggiornando hanno le texture in formato TGA+texture.txt, quindi il problema non mi si è mai posto.

 

Come ultimo tentativo, potresti:

  • aprire l'oggetto con Edit in Explorer (o il comando equivalente) in T:ANE
  • copiare la cartella dell'oggetto da qualche parte
  • importare la cartella in TRS19 con Import Content (o il comando equivalente)

Anche se questo metodo (piuttosto laborioso) funzionasse, sostituirei comunque gli oggetti, perché non è detto che chi abbia TRS19 abbia anche T:ANE.

Share this post


Link to post

Tenterò. Ma qualcosa del genere mi pare di averlo già provato. Ripeto, però, è giusto a titolo di curiosità. Quegli oggetti li ho già eliminati in TRS19

 

:ciao:

Share this post


Link to post

Per quel poco che può valere, ho fatto un esperimento con un albero built-in in TS2010 e non presente in TS12, aprendolo con "Edit|Edit in Explorer" in TS2010 ed importandolo in TS12 con "Import Content".

 

Una volta importato e committato, l'albero dà diversi avvisi:

 

Warning: This asset uses an obsolete trainz-build number. Trainz-build numbers below 2.9 are no longer supported.
Warning: Required container 'thumbnails' is missing.
Warning: The *.texture.txt file is missing for texture resource 'fet3_arbre_01-fet3_arbre_01.texture'.
Warning: The *.texture.txt file is missing for texture resource 'fet3_ombre_01-fet3_ombre_01.texture'.
 

Nonostante ciò, nel gioco si vede correttamente:

 

Pendolino_20190417_0000.thumb.jpg.5fcd9bae2fa27ee6928ad3a0878013cc.jpg

 

Non so però se il metodo sia applicabile anche all'accoppiata T:ANE / TRS19.

 

:ciao: 

 

 

Share this post


Link to post

Avendo ancora 2010 installato,posso provare a vedere che succede con T:ANE.

Il kuid è quello che si vede nella schermata, giusto?

Share this post


Link to post

Yessir! L'oggetto si chiama "FET Arbre3".

 

Senza stare a copiare la cartella, l'ho aperto con "Edit in Explorer" e l'ho importato andando a cercare la cartella "C:\Programmi x86\Auran\TS2010\UserData\Editing" (rimane comunque un metodo abbastanza macchinoso...)

  • Like 1

Share this post


Link to post

Se faccio un CDP da già errore da TS2010 a TS12 :mrgreen:.

 

Posso mandarti la cartella, e vediamo cosa succede ma comunque l'oggetto contiene dei file .TEXTURE in formato TS2010/TS12 (che sono apribili con Image2TGA e sono diversi dai file .TEXTURE di T:ANE/TRS19).

 

:ciao: 

Share this post


Link to post

! <kuid:50722:22001> VE48: This asset uses an obsolete trainz-build number. Trainz-build numbers below 3.5 are no longer supported.
; <NULL> MeshResource::LoadResource> <NULL> | arc:fld:$(local)/hash-40||kuid 50722 22001.tzarc|
; <NULL> Loading mesh fet3_arbre01.im
- <kuid:50722:22001> VE168: File 'fet3_ombre_01-fet3_ombre_01.texture' is not a valid compiled texture file for 'arc:fld:$(local)/hash-40||kuid 50722 22001.tzarc|'
- <kuid:50722:22001> VE165: Texture 'fet3_ombre_01-fet3_ombre_01.texture' is missing or could not be loaded in mesh 'fet3_arbre01.im', material '*FET3_arbre01*BD8262B7*shadow*m.onetex'.
- <kuid:50722:22001> VE168: File 'fet3_arbre_01-fet3_arbre_01.texture' is not a valid compiled texture file for 'arc:fld:$(local)/hash-40||kuid 50722 22001.tzarc|'
- <kuid:50722:22001> VE165: Texture 'fet3_arbre_01-fet3_arbre_01.texture' is missing or could not be loaded in mesh 'fet3_arbre01.im', material '*FET3_arbre01*407A5640*leaves*m.onetex'.
! <kuid:50722:22001> VE62: Required container 'thumbnails' is missing.
- <kuid:50722:22001> VE65: The *.texture.txt file is missing for texture resource 'fet3_arbre_01-fet3_arbre_01.texture'.
- <kuid:50722:22001> VE65: The *.texture.txt file is missing for texture resource 'fet3_ombre_01-fet3_ombre_01.texture'.
 

faulty

  • Thanks 1

Share this post


Link to post

:su:  Come sempre, non ci facciamo mancare nulla 😄.

Share this post


Link to post

Trattando le texture con il programmino di PEV

 

; <kuid:50722:22001> Validating <kuid:50722:22001>
! <kuid:50722:22001> VE48: This asset uses an obsolete trainz-build number. Trainz-build numbers below 3.5 are no longer supported.
! <kuid:50722:22001> VE62: Required container 'thumbnails' is missing.
 

Image2.thumb.png.296b73e8856542f6e729c4ca13e33135.png

Share this post


Link to post

Nel gioco:

 

720047823_2019-04-18003044.thumb.jpg.555c4a06416b1539175ee39cd5b97600.jpg

 

@ettore48, in allegato il cdp dell'oggetto con le texture trasformate da .texture all'usuale formato tga + texture.txt.

FET3 arbre01.cdp

 

Evito di darti la versione non compressa in cdp con i file originali, vista la sfilza di errori che già T:ANE da.

Share this post


Link to post

×
×
  • Create New...