Jump to content

sessioni e tratte


Recommended Posts

salve sono Davide.

quando ho cominciato ad utilizzare trainz su questo pc ho deciso di sfogare la mia creatività costruendo una tratta che offre parallelamente una rete tranviaria e una ferroviaria.

purtroppo , ignaro di tutto ciò , ho fatto la gran cavolata di costruire tutto sulla sessione e non sulla mappa.

recentemente non appena costruisco un po' di più e salvo la sessione , quando vado a riaprirla mi da il cerchio azzurro del caricamento all'infinito (ergo si impalla e non ci impiega i soliti 2 minuti per aprirla). 

a me no che io non salvi letteralmente ogni 3 oggetti inseriti trainz mi da questi problemi. 

ho già provato a unire sessione e tratta ma ciò non si concretizza poichè non appena clicco il pulsante di conferma la schermata si blocca e non lavora più il gioco.

ho pensato si potesse trattare della eccessiva quantità di case presenti nella città , dunque ho tolto tutto assieme ai binari del tram e relativi fili ma nulla. si blocca ancora.

non so cosa fare e non vorrei mandare in fumo un progetto assai vasto in corso d'opera. 

ve ne prego , aiutatemi.

Link to post

ciao Davide,

devi aver combinato un bel casino.....

Difficile capire cosa può essere che impalla Trainz.

Innanzi tutto precisa con che build o versione di Trainz stai lavorando e che quanta memoria hai installato sul pc, che scheda grafica stai usando.

Poi usa il Content Manager per controllare la tratta e i relativi oggetti.

Puoi avere tratta ed oggetti che sono "open to edit", devi "committarli" (submit edit), prima di  rilanciare la tratta.

Oppure sono rossi e quindi presentano errori.

Meglio fare anche un "Rebuild database" per risistemare gli oggetti.

A quanto ho capito non hai un backup precedente al problema.

 

Devi anche controllare le opzioni di installazione che hai usato e che non siano troppo "elevate" per il tuo pc.

Link to post

La tratta e la sessione non superano i 4mb.

Utilizzo nvidia gtx 1080ti.

Spazio 1000gb

Non ho oggetti open to edit o difettosi.

Trainz 12 build 59009.

Rebuilt gia fatto non va.

La tratta contiene oggetti non troppo pesanti in termini di Mb , ho ridimensionato tutte le texture grosse.

Al limite posso girarvi sul forum la tratta e sessione.

Ho provato anche ad eliminare i quadrotti e ho notato che in quelli della città si impalla per cui si tratta di un problema dentro la città ( forse dovuto ai troppi cavi e binari del tram?) .

Non saprei .

Cosa posso fare?

Grazie per la attenzione. 

 

 

 

Link to post
3 ore fa, Davide Martinelli ha scritto:

La penultima versione della mappa me la apre. 

 

Controlla quali oggetti hai inserito dopo questa versione.

Comunque puoi anche controllare (fai un list delle dipendenze della tratta) se ci sono oggetti molto "pesanti"...

Ho incontrato anche auto bellissime di 250 MB cadauna !

 

Mi spiace, non saprei che altro consigliarti, salvo passare almeno a TANE sp4 che gestisce tutto meglio. TS12 non è più supportato e molti nuovi oggetti non sono compatibili con TS12.

Oggi TANE viene venduto da N3V per pochi dollari.

 

Inoltre non precisi quanta memoria (non lo spazio libero sull'HD) ha il tuo pc.

16 GB sono il minimo per Trainz per evitare scatti e swap su HD.

Link to post

ho provato a spostare ogni singolo oggetto sullo strato della mappa . funziona.

con questo metodo sicuramente arriverei tra 4 mesi ad aver completato tutto ciò .

per cui chieo , è possibile spostare più oggetti sullo strato percorso? oppure spostare tutti i binari di una tipologia sullo strato percorso? quando con il comando " ? " dei binari intervengo su (esempio) "binario02" mi sposta sullo strato percorso solo la sezione selezionata tra due nodi.

Link to post
2 ore fa, Davide Martinelli ha scritto:

ho provato a spostare ogni singolo oggetto sullo strato della mappa . funziona.

 

Stavo giusto per suggerirti di fare l'esperimento, ma poi ho pensato che - come confermi - si sarebbero voluti mesi.

 

Che io sappia, l'unico modo possibile (che però non ti funziona) è quello di unire il livello tratta (route-layer) con quello sessione (session-layer).

 

Se vuoi provare a postare la tratta e la sessione, possiamo provare a vedere se è un problema dovuto a qualche particolarità del tuo PC o del tuo Trainz, o meno.

 

:ciao:

Link to post

Puoi inserirle come allegato ad un messaggio, oppure - se superassero le dimensioni consentite - mandarle via mail (in questo caso, avvisaci e ti manderemo gli indirizzi via MP).

 

:ciao:

Link to post
9 ore fa, Fulvio53 ha scritto:

Se ti aiutano loro Davide,forse è meglio....io ho fatto quello che ho potuto...più di così non potevo fare...

grazie comunque fulvio , io ho già ricominciato a rifarla ma se loro riescono ad aiutarmi accantono la ricostruzione

 

Link to post

Il built della tratta è 3,7, TRS12 più o meno.

abbiamo delle dipendenze built 4,6, trs 19 che mi devi far capire come le hai scaricate sul 12 perchè tale built normalmente è interdetta.

Ergo a mio modesto parere, posso anche sbagliare ma oggetti con built 4,6 in una built 3,7 non funzionano.

 

 

Link to post
1 ora fa, pegaso52 ha scritto:

Il built della tratta è 3,7, TRS12 più o meno.

abbiamo delle dipendenze built 4,6, trs 19 che mi devi far capire come le hai scaricate sul 12 perchè tale built normalmente è interdetta.

Ergo a mio modesto parere, posso anche sbagliare ma oggetti con built 4,6 in una built 3,7 non funzionano.

 

 

ho modificato nel config alcune cose per consertire il funzionamento sulla mia build

 

 

Link to post
15 ore fa, Davide Martinelli ha scritto:

grazie comunque fulvio , io ho già ricominciato a rifarla ma se loro riescono ad aiutarmi accantono la ricostruzione

 

Se loro ci riescono bene...molto bene..! Ma se ci fossero problemi te l'ho detto  dovresti rifarla da zero e salvarla sempre mappa e continuare a lavorare su di essa...almeno io ho sempre fatto così e criticità come le tue,non mi sono mai capitate,magari di altro tipo,ma penso sia stato dovuto ad altri guai intrinsechi nel programma,non credo in problemi di mappa..Purtroppo come già ripetuto fino alla nausea,i problemi già nascono sul nascere mancando una diagnostica delle avarie più gravi.e questo è un deficit che si ripercuote sul programma e sui suoi lavori.Io come ripetuto già è stato molto aver trasformato la sessione in mappa,come detto ..e altro non so dirti!!!Ma loro sicuramente hanno più esperienza e sono molto più avanti di me in tecniche informatiche,per cui se è possibile arrivare a una soluzione vedrai che la troveranno...

Link to post
12 ore fa, Davide Martinelli ha scritto:

ho modificato nel config alcune cose per consertire il funzionamento sulla mia build

 

 

 

Quali altri oggetti hai convertito oltre il sistema ATLS per trs 19 ( di cui ho MD sconosciuti in trs12)?

Link to post
×
×
  • Create New...